未能安装所需的固件更新,需要兼容的内部储存才能更新 – 解决方案

前言

在升级macOS High Sierra 10.13或 Monterey 12系统的时候,有时候会遇到“未能安装所需的固件更新,需要兼容的内部储存才能更新”这个错误提示,出现这个提示的机器,大多数都是更换过硬盘导致的。

一般两种情况:

1、本机自带是128g的硬盘,后来购买二手原装硬盘,升级到256g或更高容量。

2、使用转接卡,扩展升级了第三方NVME或NGFF固态硬盘。

问题分析

为什么更换了硬盘,在升级macOS系统的时候,就会报这个错误呢?

简单来说,就是主板固件版本低,导致升级过程校验失败。

macOS的「固件」其实类比于PC架构中的BIOS,苹果几乎每次大的版本更新的时候都会伴随「固件」的更新。

迄今为止对第三方硬件影响最大的两次固件更新第一个是macOS High Sierra 10.13的固件版本更新,在这个版本更新后,macOS开始支持了NVME,因此绝大部分NVME和NGFF的转接卡都必须在10.13版本之后才能够被正常使用。

第二个影响较大的固件更新就是跟着macOS Catalina 10.15.7的BootRom版本(195.x.x.x),在这个版本后,系统才支持在第三方SSD上进行固件更新。

解决方案

其实解决方案有好几种,但是对于普通用户来说,还是就直接上最简单的方法吧。

此内容查看价格为5技术币立即购买(VIP免费)
本站所有教程,站长均参与编辑/录制/校验,确保真实可用。内容通俗易懂,可放心购买,升级VIP享更多技术资源免费查看使用。

版权声明


本教程源自站长亲自编辑整理,仅供用户交流学习与研究使用,版权归技术之家IT工作室www.jishuzhijia.cn所有。
用户本人浏览后不能用作商业或非法用途,否则后果均由用户承担责任;
如果您喜欢该教程,请支持本站,购买注册,得到更好的优质服务。
本站VIP捐赠是您喜欢本站而产生的赞助支持行为,仅用于网站运营及服务器维护资金,全凭自愿无任何强求。

常见问题
本站压缩包解压密码统一为 www.jishuzhijia.cn
原文链接:https://jishuzhijia.cn/archives/2799.html,转载请注明出处,技术之家IT工作室。
0

评论0

请先
Wechat 微信 v3.9.9.43 防撤回补丁 Windows x64版 附带Wechat v3.9.9.43下载
Wechat 微信 v3.9.9.43 防撤回补丁 Windows x64版 附带Wechat v3.9.9.43下载
5分钟前 有人购买 去瞅瞅看
公告                        网站全新改版,为答谢新老用户支持,VIP会员,限时优惠活动开始啦~ ✌                       立即查看
显示验证码
没有账号?注册  忘记密码?